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SINUMERIK
SinuTrain for SINUMERIK Operate
Training und Programmierung
Kompaktbedienanleitung

Vorwort
Willkommen zu SinuTrain for SINUMERIK Operate - Training und Programmierung
am PC.

Mit der Schulungssoftware SinuTrain for SINUMERIK Operate lernen Sie die
Steuerung 840D sl / 828D zu bedienen und zu programmieren.

SinuTrain for SINUMERIK Operate - Training und Programmierung

Diese Dokumentation unterstützt Sie Schritt für Schritt bei folgenden Aufgaben:

● Installation der Trainings-Software von DVD

● Übertragung der Lizenz

● Starten des Programms

● Auswahl der Werkzeugmaschine

● Starten der Simulation

An wen wendet sich SinuTrain for SINUMERIK Operate?

SinuTrain for SINUMERIK Operate ist zur Aus- und Weiterbildung folgender
Zielgruppen konzipiert:

● Neueinsteiger, Umsteiger

● Ausbildungsleiter, Trainer

● Vertriebsmitarbeiter zur Kundenpräsentation

● CNC-Programmierer zur Arbeitsvorbereitung
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Informationen

Unter dem Link Technische Dokumentation Sinumerik
(https://support.industry.siemens.com/cs/document/108464614) gibt es
Informationen zu folgenden Themen:

● Dokumentation downloaden
Weiterführende Links für den Download von Dateien aus dem Siemens Industry
Online Support Portal.

● Dokumentation individuell zusammenstellen
MySupport/ Dokumentation bietet Ihnen eine Reihe von Features zur Erstellung
Ihrer eigenen Maschinendokumentation.
Siehe auch MySupport/ Dokumentation
(https://support.industry.siemens.com/My/ww/de/documentation)

● Dokumentation bestellen
Hier finden Sie die aktuelle Druckschriftenübersicht.

● Training und FAQs
Informationen zum Trainingsangebot und zu FAQs (frequently asked questions)
finden Sie über die Seitennavigation.

Rechtsgrundlagen

Diese Software (SinuTrain™) dient zum Erstellen und Simulieren von NC
Programmen auf einem PC auf Basis der Programmiersprache DIN 66025 sowie der
Produkte ShopMill, ShopTurn und Sprachbefehle vom Typ Sinumerik™ 828D und
840D sl. Die mit der Software erstellten Programme dürfen nur dann zur Fertigung
mit Werkzeugmaschinen eingesetzt werden, wenn die Software (SinuTrain/JobShop)
auf die Sinumerik angepasst wurde, auf der das erstellte Programm ablaufen soll.

Die Anpassung muss fachgerecht von autorisiertem Personal, z.B. von Siemens,
vom Werkzeugmaschinenhersteller oder vom Händler vorgenommen werden; bei der
Anpassung sind die Vorgaben von Siemens und vom Werkzeugmaschinenhersteller
zu beachten. Andernfalls kann es zu Fehlfunktionen der Werkzeugmaschine
kommen.

Im Übrigen gelten für die Software für Kunden in Deutschland die "Allgemeinen
Bedingungen zur Überlassung von Software für Automatisierungs- und
Antriebstechnik an Lizenznehmer mit Sitz in Deutschland" und für Kunden im
Ausland die "General Licence Conditions for Software Products for Automation and
Drives for Customers with a Seat or registered Office outside of Germany".CLASES PARTICULARES, TUTORÍAS TÉCNICAS ONLINE
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Technical Support

Bei technischen Fragen wenden Sie sich bitte an folgende Hotline:
Europa / Afrika

Telefon +49 0911 895 7222
Fax +49 0911 895 7223
0,14 €/Min. aus dem deutschen Festnetz, abweichende Mobilfunkpreise sind
möglich.
Internet https://www.siemens.com/automation/support-request

Amerika
Telefon +1 423 262 2522
Fax +1 423 262 2200
E-Mail mailto:techsupport.sea@siemens.com

Asien / Pazifik
Telefon +86 1064 757 575
Fax +86 1064 747 474
E-Mail mailto:support.asia.automation@siemens.com

Hinweis
Landesspezifische Telefonnummern für technische Beratung finden Sie im Internet:
https://www.automation.siemens.com/partner

Fragen zur Dokumentation

Bei Fragen zur Dokumentation (Anregungen, Korrekturen) senden Sie bitte ein Fax
oder eine E-Mail an folgende Adresse:
Fax +49 9131- 98 2176
E-Mail mailto:docu.motioncontrol@siemens.com

Internetadresse

http://www.cnc4you.siemens.com
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1 Übersicht
Die Schulungssoftware SinuTrain for SINUMERIK Operate (im folgenden SinuTrain
genannt) simuliert auf Ihrem PC eine SINUMERIK 840D sl mit der Bedienoberfläche
SINUMERIK Operate.

Hinweis
Lizenz
Um eine Maschine mit vollem Funktionsumfang zu starten, benötigen Sie eine
Lizenz.

Originalgetreue Darstellung und Verhalten

SinuTrain ermöglicht durch die originalgetreue Darstellung von Bedientafelfront,
Maschinensteuertafel und Bedienoberfläche eine reale Bedienung.

● SinuTrain beinhaltet eine Maschinensteuertafel mit spezifischen Funktionen einer
realen Steuertafel (z. B. CYCLE START, Betriebsart etc.).

● SinuTrain beinhaltet eine Bedientafel, mit der alle spezifischen Funktionen einer
realen Bedientafel genutzt werden (Hotkey etc.).

● Die Bedienoberfläche entspricht der originalen Oberfläche von SINUMERIK
Operate.

● Die Simulation verhält sich identisch zu einer echten Steuerung.

Speichern und Drucken von NC-Programmen

SinuTrain bietet die Möglichkeit, selbst erstellte NC-Programme (G-Code und
Arbeitsschrittprogramme) zu speichern.

Darüber hinaus haben Sie die Möglichkeit, ein Programm, das in der
Bedienoberfläche von SINUMERIK Operate geöffnet ist, auszudrucken.
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2 Lizenzierung mit Automation License
Manager

Sie benötigen einen gültigen Lizenzschlüssel, um in SinuTrain eine Maschine mit
vollem Funktionsumfang zu starten. Er ist Bestandteil von SinuTrain for SINUMERIK
Operate und wird auf einem USB-Stick ausgeliefert.

Für die Bedienung von SinuTrain ist keine Lizenz notwendig.

Alle Bedienbereiche und Funktionen können bedient werden.

Lizenz

Mit einer Lizenz (Seite 10) stehen Ihnen zusätzliche Funktionen zur Verfügung.

Hinweis
Informationen zur Lizenz
In der Readme erhalten Sie nähere Informationen zu Lizenzen.

Lizenz mit Automation License Manager übertragen

Voraussetzung: USB-Stick mit der zu übertragenden Lizenz.

1. Starten Sie den Automation License Manager über die Ikone oder über das
Startmenü.
Der Automation License Manager öffnet sich.

2. Schließen Sie den USB-Stick an.
Der USB-Stick wird unter "Eigener Rechner" angezeigt.

3. Markieren Sie den Eintrag "Removable Disk" auf der linken Seite.
Auf der rechten Seite sehen Sie die auf dem USB-Stick vorhandenen Lizenzen.

4. Übertragen Sie die Lizenz mit Drag&Drop auf eine lokale Festplatte.
- ODER -
Wählen Sie dazu im Kontextmenü der Lizenz "Übertragen...".

5. Wählen Sie in dem sich öffnenden Fenster das Ziel der Lizenzübertragung.
Nachdem die Lizenz übertragen ist, erscheint diese auf dem Ziellaufwerk.
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3 Lizenzmodell
Nutzung und Umfang von Funktionen der verschiedenen Vorlagenmaschinen sind
davon abhängig, ob Sie über eine Lizenz verfügen.

DEMO Maschinen

● DEMO Maschinen sind fest vorkonfigurierte Maschinen, die nicht geändert
werden können.

● Für DEMO Maschinen benötigen Sie keine Lizenz.

● Sie haben die Möglichkeit, die Maschinen zu starten und zu bedienen.

● Sie haben z.B. die Möglichkeit, Werkstücke und Teileprogramme an die
Maschine zur Programmsimulation und -anpassung zu übertragen und
anschließend zur weiteren Verwendung an CNC-Steuerungen aus der Maschine
auszuleiten.

● Ausgewählte Funktionen stehen nicht zur Verfügung. Weitere Informationen
finden Sie in der Hilfe zur CNC Software.

Vorlagenmaschinen / Importierte Maschinen / Aus IBN-Archiv erstellte Maschinen

● Sie haben die Möglichkeit, alle Maschinen zu starten und zu bedienen. Das
ermöglicht Ihnen, alle SINUMERIK-Funktionen auszuprobieren.

● Alle Maschinen verfügen über den vollen Funktionsumfang von SINUMERIK
Operate.

● Lizenz
– Ohne Lizenz

Das Übertragen von Werkstücken und Teileprogrammen an die bzw. aus der
Maschine ist nicht möglich.

– Mit Lizenz
Das Übertragen von Werkstücken und Teileprogrammen an die bzw. aus der
Maschine ist möglich.
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Hinweis
Lizenz nachträglich ablegen
Falls Sie eine Lizenz ablegen, während die Maschine bereits gestartet ist, führen Sie
einen Neustart der Maschine durch.
Erst jetzt haben Sie die Möglichkeit, die Maschine ohne Einschränkungen zu
verwenden.

Maschinen exportieren und importieren / Teileprogramme ausdrucken

Für die Funktionen "Importieren" und "Exportieren" von Maschinen sowie das
Drucken von Teileprogrammen benötigen Sie generell eine Lizenz.
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4 SinuTrain for SINUMERIK Operate

4.1 SinuTrain installieren / deinstallieren

4.1.1 Systemvoraussetzungen
Hardware

Prozessor: 2 GHz (SingleCore)

RAM: 4 GB

Festplatte:

● 3,3 GB für vollständige Installation mit allen Sprachen

● 1,2 GB für Minimalinstallation (Sprache Englisch)

DVD-Laufwerk: zur Installation über DVD-Datenträger

Grafikkarte:

● DirectX 9 oder höher mit WDDM 1.0 Treiber

● minimale Auflösung 800x600 Pixel

USB-Schnittstelle

Maus, Tastatur

Betriebssysteme

● Windows 7 (32 Bit und 64 Bit, nicht unterstützt werden Starter, Web Edition und
Embedded)

● Windows 8.1

Software

Adobe Acrobat Reader®
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4.1.2 SinuTrain installieren
Das Softwareprodukt SinuTrain for SINUMERIK Operate besteht aus verschiedenen
Softwarekomponenten, die teilweise ein eigenes Setup besitzen (z. B. Automation
License Manager).

Voraussetzung

Für das uneingeschränkte Arbeiten mit angelegten Maschinen benötigen Sie einen
Lizenzschlüssel. Dieser muss vor dem ersten Start einer Maschine auf den PC
übertragen werden. Zu diesem Zweck wird bei der Installation von SinuTrain ein
zusätzliches Programm installiert – der Automation License Manager. Mit Hilfe des
Automation License Manager wird der Lizenzschlüssel auf den PC übertragen.

Vorgehensweise

1. Doppelklicken Sie auf die "setup.exe" im Wurzelverzeichnis der DVD.
Bei aktivierter Benutzerkontensteuerung erscheint nach einem Doppelklick auf
die "setup.exe" eine Systemabfrage. Mit dieser Abfrage stimmen Sie zu, dass das
Setup Änderungen an Ihrem System vornehmen darf (diese Abfrage stammt aus
Windows und ist kein von Siemens erstellter Bestandteil). Bestätigen Sie diesen
Dialog und fahren Sie mit der Installation fort.

2. Wählen Sie die Setup-Sprache und klicken Sie auf die Schaltfläche "Weiter >".

3. Lesen Sie die Hinweise zu Installation und Programmnutzung und klicken Sie auf
die Schaltfläche "Weiter >".

4. Klicken Sie auf die Schaltfläche "Liesmich" und lesen Sie den Liesmich-Text mit
den Produkthinweisen, schließen Sie anschließend die Liesmich-Datei wieder
und klicken Sie auf die Schaltfläche "Weiter >".

5. Lesen Sie die Lizenzvereinbarung und aktivieren Sie anschließend das
Kontrollkästchen, um die Lizenzvereinbarung und die Sicherheitshinweise zu
akzeptieren und klicken Sie auf die Schaltfläche "Weiter >".

6. Wählen Sie die Sprachen aus, in der Sie SinuTrain for SINUMERIK Operate
installieren wollen.
Die ausgewählten Sprachen stehen Ihnen in SinuTrain sowie SINUMERIK
Operate zur Verfügung.

7. Aktivieren Sie im Fenster "Programme" die gewünschten Kontrollkästchen und
klicken Sie auf die Schaltfläche "Weiter>".
Wenn Sie den Installationspfad der einzelnen Produkte ändern wollen, markieren
Sie das jeweilige Produkt, klicken Sie auf die Schaltfläche "Durchsuchen" und
wählen Sie den gewünschten Ordner.
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Hinweis
Vor der Installation von SinuTrain wird unter Umständen eine automatische
Installation von Systemaktualisierungen durchgeführt, die eventuell einen
Neustart des Rechners notwendig macht. Das Setup wird nach dem Neustart des
PC anschließend automatisch fortgesetzt.

Die Installation von SinuTrain und Automation License Manager beginnt.
Nach Beendigung der Installation von SinuTrain erhalten Sie eine entsprechende
Information.

8. Klicken Sie auf die Schaltfläche "Beenden".
SinuTrain sowie Automation License Manager sind betriebsbereit.

Hinweis
Benutzerkontensteuerung
Wenn bei der Abfrage der Benutzerkontensteuerung als Herausgeber "Unbekannt"
steht, verneinen Sie die Abfrage und melden Sie sich bei der Hotline.
Alle frei gegebenen Produkte von Siemens sind mit einem Zertifikat versehen,
wodurch bei der Abfrage als Herausgeber stets die Siemens AG angegeben sein
wird.

Hinweis
Klicken Sie auf die Schaltfläche "Abbrechen", um die Installation wieder zu verlassen.

Hinweis
Es wird empfohlen, die Installation nicht aus einem Netzlaufwerk heraus zu starten,
da es wegen eventuell erforderlichen Systemaktualisierungen zu Problemen
kommen kann.

4.1.3 SinuTrain deinstallieren

Vorgehensweise

1. Wählen Sie im Windows-Menü Start > Systemsteuerung.

2. Doppelklicken Sie in der Liste der Systemsteuerung auf "Programme und
Funktionen" (Windows 7).

3. Wählen Sie in der Software-Liste "SinuTrain Workbench 1.2" und klicken Sie auf
die Schaltfläche "Deinstallieren".

4. Wählen Sie in der Software-Liste die installierten Versionen von "SinuTrain
SINUMERIK CNC-SW" und klicken Sie auf die Schaltfläche "Deinstallieren".

CLASES PARTICULARES, TUTORÍAS TÉCNICAS ONLINE
LLAMA O ENVÍA WHATSAPP: 689 45 44 70

- - -
ONLINE PRIVATE LESSONS FOR SCIENCE STUDENTS
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4.2 SinuTrain bedienen

4.2.1 So funktioniert SinuTrain

Voraussetzung

SinuTrain for SINUMERIK Operate ist installiert.

Allgemeiner Ablauf

● Sprache auswählen
Beim erstmaligen Start wählen Sie die gewünschte Sprache für SinuTrain und
SINUMERIK Operate.

● SinuTrain starten
Nach Bestätigung des Nutzungshinweises öffnet sich SinuTrain mit der
Maschinenübersicht.

● Maschine anlegen
In der Maschinenübersicht legen Sie eine Maschine an.
Dabei wählen Sie zunächst über Vorlagen eine Maschine des gewünschten Typs.
Anschließend legen Sie Namen und Kurzbeschreibung der Maschine fest, wählen
evtl. ein eigenes Maschinenbild für die Maschinenübersicht und legen Auflösung
und Sprache der Maschinensimulation in der SINUMERIK Operate
Bedienoberfläche fest.

● Maschine starten
Die Maschinensimulation öffnet sich mit Bedientafel und Bedienoberfläche
SINUMERIK Operate, Maschinensteuertafel mit Vorschub- und Spindeloverride
sowie CNC-Tastatur.

● Maschine simulieren
Die simulierte Maschine können Sie jetzt wie eine echte Maschine bedienen und
z. B. Programme erstellen.

CLASES PARTICULARES, TUTORÍAS TÉCNICAS ONLINE
LLAMA O ENVÍA WHATSAPP: 689 45 44 70
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4.2.2 Maschinenübersicht
In der Maschinenübersicht legen Sie Maschinen an, parametrieren und verwalten die
Maschinenkonfigurationen, mit denen Sie trainieren.

① Funktionskachel mit Optionen zur Anlage von Maschinenkonfigurationen
② SinuTrain-Menü
③ Maschinenübersicht mit allen angelegten Maschinen
④ Informationskachel mit Beschreibung der selektierten Maschinenkonfiguration
⑤ Angelegte Maschinenkonfiguration mit Maschinenname und CNC

Softwareversion
⑥ Selektierte Maschinenkonfiguration

CLASES PARTICULARES, TUTORÍAS TÉCNICAS ONLINE
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Siehe auch

Menübefehle (Seite 43)

Kontextmenü (Seite 46)

Übersicht (Seite 22)

Maschine aus Vorlage erstellen (Seite 23)

Maschine kopieren und konfigurieren (Seite 25)

Maschine importieren (Seite 25)

Maschine aus Inbetriebnahmearchiv erstellen (Seite 28)

4.2.3 Bildschirmeinteilung der Maschinensimulation

Bedienoberfläche von SinuTrain

① SinuTrain-Menü
② Bedienoberfläche SINUMERIK Operate
③ Bedienelemente einer Bedientafel
④ Maschinensteuertafel mit Vorschub- und Spindeloverride

CLASES PARTICULARES, TUTORÍAS TÉCNICAS ONLINE
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Siehe auch

Menübefehle (Seite 43)

4.2.4 Sprachen installieren

4.2.4.1 Zusätzliche Sprachen für SinuTrain installieren
Bei der Installation von SinuTrain for SINUMERIK Operate wählen Sie die
gewünschte Sprache. Dabei wird die Bedienoberfläche von SINUMERIK Operate in
der gewählten Sprache mit installiert.

Folgende Standardsprachen stehen bei der Installation zur Auswahl: Deutsch,
Englisch, Französisch, Italienisch, Spanisch und Chinesisch vereinfacht.

SinuTrain-Sprachen nachinstallieren

Wenn Sie bei der Installation von SinuTrain eine der Standardsprachen nicht
ausgewählt haben, kann durch ein erneutes Setup (Reparaturinstallation) die
gewünschte Sprache nachträglich installiert werden. Damit steht dann auch
SINUMERIK Operate in der Sprache zur Verfügung.

4.2.4.2 Zusätzliche Sprachen für SINUMERIK Operate
installieren

Sie haben die Möglichkeit, weitere Sprachen für die SINUMERIK Operate
Bedienoberfläche zu installieren.

Zusatzsprachen installieren

Zusätzliche Sprachpakete werden auf folgender Internetadresse zum Download
angeboten:

http://www.cnc4you.siemens.com (http://www.cnc4you.siemens.com)

CLASES PARTICULARES, TUTORÍAS TÉCNICAS ONLINE
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Vorgehensweise

1. Wählen Sie den Menübefehl Extras > HMI Zusatzsprachen installieren....
Das Fenster "HMI Zusatzsprachen installieren" öffnet sich.

2. Klicken Sie auf die Schaltfläche "..." und navigieren Sie im Dialog "Öffnen" zum
Ablageort der Sprachpakete.

3. Wählen Sie die gewünschte Sprachdatei (*.slf) und klicken Sie auf die
Schaltfläche "Öffnen".
Sie kehren ins Fenster "HMI Zusatzsprachen installieren" zurück.
Der Ablagepfad ist eingetragen. Die gewählte Sprache wird angezeigt und mit
einem Flaggensymbol gekennzeichnet. Zusätzlich werden die Version des
SINUMERIK Operate Sprachpakets und der Steuerungstyp angezeigt.

4. Wählen Sie gegebenenfalls den CNC-Softwarestand, für den das Sprachpaket
installiert werden soll.

5. Klicken Sie auf die Schaltfläche "Installieren".
Ein Fortschrittsbalken zeigt den Installationsvorgang an.
Nach erfolgreicher Installation erhalten Sie eine Meldung.

6. Klicken Sie auf die Schaltfläche "OK", um die Installation fertig zu stellen.

Hinweis
Sie haben die Möglichkeit, den Hinweis zur erfolgreichen Installation für zukünftige
Installationen von Sprachpaketen auszuschalten. Aktivieren Sie hierfür das
Kontrollkästchen "Diesen Hinweis nicht wieder anzeigen".
Wählen Sie den Menübefehl Extras > Optionen und aktivieren Sie im Fenster
"Optionen" das Kontrollkästchen "Abschluss der Sprachinstallation melden", um den
Hinweis für zukünftige Installationen wieder einzuschalten.

CLASES PARTICULARES, TUTORÍAS TÉCNICAS ONLINE
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ONLINE PRIVATE LESSONS FOR SCIENCE STUDENTS
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4.2.5 SinuTrain-Sprache ändern
Sie haben die Möglichkeit, die Sprache (Deutsch, Englisch, Französisch, Spanisch,
Italienisch, Chinesisch vereinfacht) der Bedienoberfläche von SinuTrain
umzuschalten.

Alle beim Setup oder nachträglich installierten Sprachen lassen sich auswählen.

Hinweis
SinuTrain-Sprache nachinstallieren
Haben Sie bei der Installation von SinuTrain eine der Standardsprachen nicht
ausgewählt, haben Sie die Möglichkeit über ein erneutes Setup
(Reparaturinstallation) die gewünschte Sprache nachträglich zu installieren.

Vorgehensweise

1. Wählen Sie den Menübefehl Extras > Optionen.

2. Wählen Sie in der Auswahlliste "Sprache der SinuTrain Oberfläche" die
gewünschte Sprache und klicken Sie auf "OK".

Hinweis
Sprache von SINUMERIK Operate ändern
In SINUMERIK Operate ändern Sie über die Tastenkombination <CTRL + L> oder im
Bedienbereich "Inbetriebnahme" mit Hilfe des Softkeys "Change language" die
Sprache der Bedienoberfläche von SINUMERIK Operate.

Siehe auch

Zusätzliche Sprachen für SINUMERIK Operate installieren (Seite 18)
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4.3 Mit SinuTrain arbeiten

4.3.1 SinuTrain starten und beenden

SinuTrain starten

1. Wählen Sie den Menübefehl Programme > SinuTrain for SINUMERIK Operate  >
SinuTrain.
- ODER -
Doppelklicken Sie auf das Symbol für SinuTrain auf Ihrem Desktop.

Beim erstmaligen Start wird ein Dialog zur Auswahl der Sprache der SinuTrain-
Bedienoberfläche sowie SINUMERIK Operate geöffnet.

2. Wählen Sie die gewünschte Sprache und klicken Sie auf die Schaltfläche
"Weiter".
Hinweis: Es stehen Ihnen hier die Sprachen zur Verfügung, die Sie bei der
Installation von SinuTrain ausgewählt haben.
Ein Nutzungshinweis für SinuTrain for SINUMERIK Operate wird geöffnet.

3. Klicken Sie auf "OK", um das Programm zu starten.
Die Maschinenübersicht öffnet sich.

CLASES PARTICULARES, TUTORÍAS TÉCNICAS ONLINE
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Hinweis
Sie haben die Möglichkeit, den Nutzungshinweis für zukünftige Programmstarts
auszuschalten. Aktivieren Sie hierfür das Kontrollkästchen "Diesen Hinweis nicht
wieder anzeigen".
Wählen Sie den Menübefehl Extras > Optionen und aktivieren Sie im Fenster
"Optionen" das Kontrollkästchen "Nutzungshinweis bei Programmstart anzeigen", um
den Hinweis für zukünftige Starts wieder einzuschalten.

SinuTrain beenden

● Wählen Sie den Menübefehl Datei > Beenden.
SinuTrain schließt sich.

Siehe auch

Zusätzliche Sprachen für SinuTrain installieren (Seite 18)

4.3.2 Maschine anlegen

4.3.2.1 Übersicht
Sie haben folgende Möglichkeiten, eine Maschine anzulegen:

● Maschine aus Vorlage erstellen (Seite 23)
Grundlage sind mitgelieferte Standardkonfigurationen für Dreh- und
Fräsmaschinen.

● Maschine kopieren und konfigurieren (Seite 25)
Grundlage ist eine von Ihnen zuvor angelegte Maschinenkonfiguration, die in der
Maschinenübersicht bereits vorhanden ist.

● Maschine importieren (Seite 25)
Grundlage ist eine exportierte Maschinenkonfiguration, die Sie importieren und
modifizieren.

● Maschine aus Inbetriebnahmearchiv erstellen (Seite 28)
Grundlage ist ein Inbetriebnahmearchiv (*.arc).
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4.3.2.2 Maschine aus Vorlage erstellen

Voraussetzung

SinuTrain ist gestartet und die Maschinenübersicht ist geöffnet.

Maschine aus einer Vorlage erstellen

1. Klicken Sie in der Funktionskachel "Neue Maschine erstellen" auf die Option
"Vorlage verwenden".

- ODER -
Wählen Sie den Menübefehl Datei > Neu > aus einer Vorlage....
Der Dialog "Neue Maschine erstellen - Vorlage verwenden" wird geöffnet.

Hinweis
Je nach verfügbarer SINUMERIK Version stehen Ihnen verschiedene
Vorlagenmaschinen zur Verfügung.

2. Öffnen Sie die Auswahlliste "Maschinentyp" und wählen Sie die gewünschte
Vorlage.
Sie haben die Möglichkeit, in dem sich öffnenden Datenbaum zu jedem System
(z.B. 840D sl) die gewünschte CNC-Software (z.B. 4.7) auszuwählen.
Nach der Auswahl wird im Anzeigefeld "Erstellt mit CNC-SW" System und
Software-Version der gewählten Maschine angezeigt.

3. Geben Sie im Eingabefeld "Maschinenname" den gewünschten Namen für die
Maschine ein (z. B. Meine Maschine).

CLASES PARTICULARES, TUTORÍAS TÉCNICAS ONLINE
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4. Geben Sie im Eingabefeld "Beschreibung" eventuell eine Kurzbeschreibung ein.

5. Wählen Sie die Auflösung der Maschinenoberfläche (z. B. 1024 x 768).

6. Wählen Sie die Sprache der Maschinenoberfläche (z. B. Englisch).

7. Wenn Sie für die Darstellung der Maschine ein eigenes Maschinenbild
verwenden wollen, klicken Sie auf die Schaltfläche "..." neben dem Feld "Bild
importieren", navigieren Sie im Dialog "Öffnen" zum Ablageort der Grafik
(*.png,*.jpg,*.bmp) und klicken Sie auf "OK".
Sie kehren in das Fenster "Neue Maschine erstellen - Vorlage verwenden"
zurück. Der Ablagepfad wird angezeigt.

8. Klicken Sie auf die Schaltfläche "Erstellen".

Hinweis
Wenn bereits eine Maschine mit demselben Namen vorhanden ist, erhalten Sie
einen Hinweis. Klicken Sie auf "OK" und geben Sie einen neuen
Maschinennamen ein.

In der Übersicht wird die erstellte Maschinenkonfiguration für
SINUMERIK 840D sl eingefügt.
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4.3.2.3 Maschine kopieren und konfigurieren

Voraussetzung

● SinuTrain ist gestartet und die Maschinenübersicht ist geöffnet.

● Es sind Maschinen angelegt.

Neue Maschinenkonfiguration erstellen

1. Wählen Sie in der Maschinenübersicht die Maschinenkonfiguration, die Sie
kopieren und für eine weitere Maschine verwenden wollen.

2. Wählen Sie den Menüpunkt Datei > Kopieren und einfügen.
- ODER -
Wählen Sie aus dem Kontextmenü der rechten Maustaste "Kopieren und
einfügen".
Die Maschine wird der Maschinenübersicht hinzugefügt und durch eine Nummer
im Maschinennamen kenntlich gemacht.

3. Wählen Sie anschließend für die kopierte Maschine den Menüpunkt Maschine >
Einstellungen....
- ODER -
Wählen Sie aus dem Kontextmenü der rechten Maustaste "Einstellungen...".
Der Dialog "Maschine bearbeiten" wird geöffnet.

4. Geben Sie die gewünschten Änderungen ein (z. B. Maschinenname, Auflösung,
Sprache, Maschinenbild) und klicken Sie auf die Schaltfläche "Speichern und
schließen".

Siehe auch

Maschineneinstellungen ändern (Seite 30)

4.3.2.4 Maschine importieren

Voraussetzungen

● Sie verfügen über eine Lizenz.

● SinuTrain ist gestartet und die Maschinenübersicht ist geöffnet.

● Sie haben Maschinenkonfigurationen zur Sicherung bzw. als Ausgangspunkt für
spätere Maschinenkonfigurationen exportiert.
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Hinweis
Unterschiedliche SINUMERIK CNC-Systemsoftware-Versionen
Der SINUMERIK CNC-Systemsoftware-Stand der zu importierenden Datei steht mit
SinuTrain for SINUMERIK Operate zur Verfügung. Bei unterschiedlichen Versionen
sind nachträglich manuelle Änderungen entsprechend den NC-Hochrüstanleitungen
nötig.

Maschine importieren

1. Klicken Sie in der Funktionskachel "Neue Maschine erstellen" auf die Option
"Maschine importieren".

- ODER -
Wählen Sie den Menüpunkt Datei > Importieren....
Das Fenster "Neue Maschine erstellen - Maschine importieren" wird geöffnet.

2. Klicken Sie neben dem Feld "Ausgewählte Datei" auf die Schaltfläche "..." und
navigieren Sie im Dialog "Öffnen" zum Ablageort der exportierten
Konfigurationen.

3. Wählen Sie die gewünschte Maschinenkonfigurationsdatei (*.set) und klicken Sie
auf die Schaltfläche "Öffnen".
Sie kehren in das Fenster "Neue Maschine erstellen - importieren" zurück:
– Im Feld "Ausgewählte Datei" wird der Ablagepfad angezeigt.
– Im Feld "Erstellt mit CNC-SW" wird angezeigt, unter welcher SINUMERIK

CNC-Software-Version und mit welchem System (z. B. 840D sl) die
Maschinenkonfiguration erzeugt wurde.
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4. Falls Sie mehrere Versionen der CNC-Software installiert haben, können Sie im
Feld "Übernehmen in" auswählen, für welchen Softwarestand die Maschine
erstellt werden soll.

5. Ändern Sie bei Bedarf die gewünschten Einstellungen (z. B. Maschinennamen,
Beschreibung etc.) und importieren Sie evtl. ein eigenes Maschinenbild.

Hinweis
Beachten Sie, dass es in der Maschinenübersicht keine Maschinen mit
identischem Namen geben kann.
Ändern Sie im Fenster "Neue Maschine erstellen - importieren" immer den
Maschinennamen, auch wenn Sie die Ausprägung der Maschine nicht ändern
wollen.

6. Wenn Sie die ausgewählte Konfiguration zukünftig als Vorlage für weitere
Maschinen verwenden wollen, aktivieren Sie die Checkbox "Maschine in die Liste
der Vorlagenmaschinen übernehmen".

7. Klicken Sie auf die Schaltfläche "Erstellen".

Hinweis
Warnhinweise und Meldungen
Treten beim Importieren der Maschinenkonfiguration Probleme auf, öffnet sich ein
Hinweisfenster mit entsprechenden Meldungen. Dabei werden Elemente (z. B.
Zyklen), die nicht fehlerfrei importiert wurden, mit entsprechenden
Beschreibungen aufgelistet.
Klicken Sie auf die Schaltfläche "OK", um den Hinweis zu schließen.

Sie kehren in die Maschinenübersicht zurück und die Maschine ist angelegt.
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4.3.2.5 Maschine aus Inbetriebnahmearchiv erstellen
Beachten Sie bei der Erstellung von Maschinen aus Inbetriebnahmearchiven
folgende Bedingungen:

● SINUMERIK CNC-Systemsoftware-Stand und SinuTrain for SINUMERIK Operate
Version müssen übereinstimmen, sonst ist evtl. eine Anpassung der
Maschinenkonfiguration nicht möglich.

Hinweis
Manuelle Anpassung der Maschinenkonfiguration
Wenn eine Anpassung nicht möglich ist, sind nachträglich manuelle Änderungen
entsprechend den NC-Hochrüstanleitungen nötig.

● Wenn Daten enthalten sind, die für die Verwendung in SinuTrain nicht geeignet
bzw. erforderlich sind (z. B. für PLC oder Antriebe), wird die
Maschinenkonfiguration angepasst.

Hinweis
Eine Übersicht aller angepassten Maschinendaten finden Sie in der Online-Hilfe
zur CNC-Sofware. Wählen Sie den Menübefehl Hilfe > Hilfe zu SINUMERIK
CNC-SW > und den entsprechenden Softwarestand.

● Das IBN-Archiv muss alle NC-Daten enthalten.

● Inbetriebnahmearchive von powerline-Systemen und HMI-Advanced / Embedded
können nicht verwendet werden.

Voraussetzung

● Sie verfügen über eine Lizenz.

● SinuTrain ist gestartet und die Maschinenübersicht ist geöffnet.
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Maschine aus einem Inbetriebnahmearchiv erstellen

1. Klicken Sie in der Funktionskachel "Neue Maschine erstellen" auf die Option
"IBN-Archiv einlesen".

- ODER -
Wählen Sie den Menübefehl Datei > Neu > aus einem IBN-Archiv....
Der Dialog "Neue Maschine erstellen - IBN-Archiv einlesen" wird geöffnet.

2. Klicken Sie auf die Schaltfläche "..." neben dem Feld "Ausgewählte Datei",
navigieren Sie im Dialog "Öffnen" zu dem Ablageort der gewünschten Archiv-
Datei (*.arc), selektieren Sie die Datei und klicken Sie auf die Schaltfläche
"Öffnen".
Ein Hinweis-Fenster informiert Sie darüber, dass das Archiv untersucht wird.
Sie kehren in den Dialog zurück und die ausgewählte Datei wird mit dem
Verzeichnis-Pfad angezeigt.
Zusätzlich werden Steuerungstyp und Softwareversion von SINUMERIK Operate
angezeigt.
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Hinweis
Hinweismeldungen
Sie erhalten evtl. nach dem Einlesen des Inbetriebnahme-Archivs ein Fenster mit
Hinweismeldungen, die auf mögliche Fehler und Probleme hinweisen.
Sie haben die Möglichkeit, die in der Spalte "Beschreibung" eingetragenen
Zahlen über die Schaltfläche zu kopieren, um sie dann zur Analyse an die Hotline
(Seite 3) zu senden.

3. Falls Sie mehrere Versionen der CNC-Software installiert haben, können Sie im
Feld "Übernehmen in" auswählen, für welchen Softwarestand die Maschine
erstellt werden soll.

4. Geben Sie die gewünschten Angaben zur Maschinenkonfiguration (Name und
Beschreibung) in den entsprechenden Eingabefeldern ein, importieren Sie evtl.
ein eigenes Maschinenbild und wählen Sie Auflösung (z. B. 1024 x 768) und
Sprache (z. B. Englisch) der Maschinenoberfläche.

5. Wenn Sie das ausgewählte Archiv zukünftig als Vorlage für weitere Maschinen
verwenden wollen, aktivieren Sie die Checkbox "Maschine in die Liste der
Vorlagenmaschinen übernehmen".

6. Klicken Sie auf die Schaltfläche "Erstellen".

Hinweis
Wenn bereits eine Maschine mit demselben Namen vorhanden ist, erhalten Sie
einen Hinweis. Klicken Sie auf "OK" und geben Sie einen neuen
Maschinennamen ein.

In der Übersicht wird die erstellte Maschinenkonfiguration eingefügt und zeigt das
System (z. B. 840D sl) und die SINUMERIK CNC-Software-Version an.

4.3.3 Maschineneinstellungen ändern
Sie haben die Möglichkeit, folgende Einstellungen für eine Maschine zu ändern:

● Allgemein
– Maschinenname
– Beschreibung

● Sprache
Sprache der Maschinenoberfläche (Deutsch, Englisch, Französisch, Spanisch,
Italienisch, Chinesisch vereinfacht). Zur Auswahl stehen nur die Sprachen zur
Verfügung, die bei der Installation gewählt wurden.
Haben Sie nachträglich Zusatzsprachen installiert, stehen diese hier ebenfalls zur
Auswahl.
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● Auflösung
Auflösung der Maschinenoberfläche
– 640x480
– 800x600
– 1024x768
– 1280x1024

● Bild importieren
Eigene Maschinenbilder können in folgenden Formaten hinterlegt werden:
– PNG
– JPG
– BMP

Vorgehensweise

1. Wählen Sie in der Maschinenübersicht die Maschine, für die Sie die Einstellungen
ändern wollen.

2. Wählen Sie den Menübefehl Maschine > Einstellungen....
- ODER -
Wählen Sie aus dem Kontextmenü der rechten Maustaste "Einstellungen...".
Der Dialog "Maschine bearbeiten" wird geöffnet.

3. Geben Sie die gewünschten Änderungen ein und klicken Sie auf "Speichern und
schließen".

4.3.4 Maschinenkonfiguration exportieren
Sie haben die Möglichkeit, die von Ihnen konfigurierten Maschinen zu exportieren,
um sie zu sichern. Die exportierten Maschinenkonfigurationen stehen Ihnen so als
Ausgangspunkt für spätere Maschinenkonfigurationen oder als Sicherheitskopie zur
Verfügung. Hierzu importieren Sie dann die gespeicherte
Maschinenkonfigurationsdatei.

Exportierte Maschinenkonfigurationen ermöglichen es Ihnen, diese zwischen zwei
Rechnern auszutauschen oder später in neuere SinuTrain-Versionen zu importieren.

Voraussetzung
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Vorgehensweise

1. Wählen Sie in der Maschinenübersicht die Maschinenkonfiguration, die Sie
exportieren wollen.

2. Wählen Sie den Menüpunkt Datei > Exportieren....
- ODER -
Wählen Sie aus dem Kontextmenü der rechten Maustaste "Exportieren...".
Der Dialog "Speichern unter" öffnet sich.

3. Navigieren Sie zu dem gewünschten Ablageort, ändern Sie bei Bedarf den
Dateinamen und klicken Sie auf die Schaltfläche "Speichern".
Nach erfolgreichem Export erhalten Sie eine Meldung.

4. Klicken Sie auf die Schaltfläche "OK", um den Export fertig zu stellen.

Hinweis
Sie haben die Möglichkeit, den Hinweis zum erfolgreichen Export auszuschalten.
Aktivieren Sie hierfür das Kontrollkästchen "Diesen Hinweis nicht wieder anzeigen".
Wählen Sie den Menübefehl Extras > Optionen und aktivieren Sie im Fenster
"Optionen" das Kontrollkästchen "Abschluss des Maschinenexports melden", um den
Hinweis für zukünftige Exporte wieder einzuschalten.

4.3.5 Maschine löschen
Benötigen Sie eine Maschinenkonfiguration nicht mehr, löschen Sie diese aus der
Maschinenübersicht.

Vorgehensweise

1. Wählen Sie die Maschine, die Sie aus der Liste Maschinenkonfigurationen
entfernen wollen.

2. Wählen Sie den Menübefehl Datei > Löschen.
- ODER -
Wählen Sie aus dem Kontextmenü der rechten Maustaste "Löschen".

3. Bestätigen Sie den Hinweis auf den möglichen Verlust von Daten mit "OK" und
klicken Sie im anschließenden Nachfragedialog auf die Schaltfläche "Ja", um die
Maschine zu löschen.
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Hinweis
SinuTrain-Maschine mit Anwenderdaten
Beim Löschen einer Maschine gehen sämtliche Anwenderdaten (z. B. NC-
Programme, Nullpunktverschiebungen etc.) verloren. Die Daten einer gelöschten
Maschine sind nicht wiederherstellbar.

Hinweis
Sie haben die Möglichkeit, den Hinweis auf Datenverlust für zukünftige
Löschvorgänge auszuschalten. Aktivieren Sie hierfür das Kontrollkästchen "Diesen
Hinweis nicht wieder anzeigen".
Wählen Sie den Menübefehl Extras > Optionen und aktivieren Sie im Fenster
"Optionen" das Kontrollkästchen "Vor dem Löschen auf möglichen Datenverlust
hinweisen", um den Hinweis für zukünftige Löschvorgänge wieder einzuschalten.

4.3.6 Programm ausdrucken
Sie haben die Möglichkeit, den Inhalt von Textdateien (z. B. NC-Programme) mit
einem am PC konfigurierten Drucker (lokale Drucker, Netzwerkdrucker) direkt über
SinuTrain aus der SINUMERIK Operate Bedienoberfläche zu drucken.

Sie können G-Code Programme sowie ShopMill- bzw. ShopTurn-
Arbeitsschrittprogramme mit G-Code drucken.

Layout festlegen

Im Fenster "Druckeinstellungen" legen Sie das Layout für den Druck fest, bestimmen
den Umfang des NC-Programms, der gedruckt werden soll, und konfigurieren die
Darstellung des Programms.

Einstellungen Auswirkung
Ränder
(mm) Links: Rechts:

Hier definieren Sie die Seitenränder des
Ausdrucks.
Legt den Abstand zwischen oberem,
unterem, rechtem und linkem Seitenrand
und dem jeweiligen Rand der Zeilen in mm
fest.

Oben: Unten:
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Einstellungen Auswirkung
Druck-
bereich

Alles

Hier legen Sie den Umfang des
Programmausdrucks fest.
Legt fest, dass das ganze NC-Programm
ausgedruckt wird.

Zeilen
von: bis:

Legt die Zeilen des NC-Programms fest,
die ausgedruckt werden.

Ausgewählter Bereich Legt fest, dass nur der im Editor markierte
Teil des NC-Programms ausgedruckt wird.

Programme als Text drucken Legt fest, dass Arbeitsschrittprogramme
(ShopMill/ShopTurn) als G-Code
ausgedruckt werden.

Programme mit grafischen
Abbildungen drucken

Legt fest, dass Arbeitsschrittprogramme
(ShopMill/ShopTurn) so gedruckt werden,
wie sie im Editor erscheinen.

Programme mit
Eingabemasken
drucken

Legt fest, dass zusätzlich die
Parametermasken für die Arbeitsschritte
ausgedruckt werden.

Zugeklappte Blöcke
drucken

Legt fest, dass bei Verwendung von
Programmblöcken die Programmsätze in
den Blöcken mit ausgedruckt werden.

Voraussetzung

Um aus der SINUMERIK Operate Bedienoberfläche zu drucken, benötigen Sie eine
Lizenz.

Vorgehensweise
1. Wählen Sie im Ablageverzeichnis des Programm-Managers das

Programm, das Sie ausdrucken wollen.

2. Positionieren Sie den Cursor auf das Programm und drücken Sie
den Softkey "Öffnen".
Das Programm öffnet sich im Editor.

3. Wählen Sie den Menübefehl Datei > Druckeinstellungen... .
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4. Geben Sie im Fenster "Druckeinstellungen" die Abstände für die
Seitenränder ein, legen Sie den Druckbereich und die
Darstellungsform des Programms fest und klicken Sie auf die
Schaltfläche "OK", um Ihre Angaben zu bestätigen.

5. Wählen Sie den Menübefehl Datei > Drucken.
Der Dialog "Drucken" mit dem aktivierten Standard-Drucker
(lokale Drucker, Netzwerkdrucker) öffnet sich.

6. Klicken Sie auf die Schaltfläche "Drucken".
Je nach Festlegung des Druckbereichs wird das gesamte
Programm, eine bestimmte Anzahl von Zeilen des Programms
oder ein markierter Bereich des Programms ausgedruckt.

4.3.7 Maschine starten und herunterfahren

Voraussetzung

● In der Maschinenübersicht stehen Maschinenkonfigurationen zur Verfügung.

● Um den gesamten Funktionsumfang nutzen zu können, benötigen Sie eine
Lizenz. Informationen zu Funktionseinschränkungen finden Sie unter
Lizenzmodell (Seite 10).

Maschine starten

Die Maschinenübersicht ist geöffnet.

1. Wählen Sie in der Liste der Maschinenkonfigurationen die gewünschte Maschine.

2. Wählen Sie den Menübefehl Maschine > Starten.
- ODER -
Wählen Sie aus dem Kontextmenü der rechten Maustaste "Starten".
- ODER -

CLASES PARTICULARES, TUTORÍAS TÉCNICAS ONLINE
LLAMA O ENVÍA WHATSAPP: 689 45 44 70

- - -
ONLINE PRIVATE LESSONS FOR SCIENCE STUDENTS
CALL OR WHATSAPP:689 45 44 70

www.cartagena99.com no se hace responsable de la información contenida en el presente documento en virtud al
Artículo 17.1 de la Ley de Servicios de la Sociedad de la Información y de Comercio Electrónico, de 11 de julio de 2002.
Si la información contenida en el documento es ilícita o lesiona bienes o derechos de un tercero háganoslo saber y será retirada.



SinuTrain for SINUMERIK Operate

Training und Programmierung
36 A5E38756522, 07/2016

Klicken Sie auf den Pfeil in der Maschinenkonfiguration.

Die Maschinensimulation mit Bedientafel und Bedienoberfläche SINUMERIK
Operate, Maschinensteuertafel mit Vorschub- und Spindeloverride sowie CNC-
Tastatur öffnet sich.

3. Sie bedienen SINUMERIK Operate mit Hilfe der Maus oder einer Standard-
Tastatur.

4. Klicken Sie bei der Bedienung von SINUMERIK Operate auf die Taste <HELP>
oder drücken Sie die Taste <F12>, um sich die kontextsensitive Online-Hilfe für
die Fenster und Eingabemasken von SINUMERIK Operate anzeigen zu lassen.

ACHTUNG
Datenverlust beim außerplanmäßigen Beenden von Sinutrain
Wenn das Betriebssystem das Beenden von Sinutrain forciert (z. B. beim Abmelden
des aktuellen Benutzers), werden nur die NCK-Daten der aktuell laufenden
Maschine gesichert. Änderungen an den Einstellungen der Maschine und an den
HMI-Daten gehen verloren.
Um diesen Datenverlust zu verhindern, fahren Sie die Maschine regelmäßig
herunter.
Weitere Informationen finden Sie im Abschnitt Unerwartetes Beenden von
SinuTrain (Seite 37).

Maschine herunterfahren

● Wählen Sie den Menübefehl Maschine > Herunterfahren, wenn Sie die aktuelle
Maschinenkonfiguration verlassen wollen.
Sie kehren in die Maschinenübersicht zurück.
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Maschine neu starten

● Wählen Sie den Menübefehl Maschine > Neu starten, wenn Sie die aktuelle
Maschinenkonfiguration zum Beispiel nach Änderungen von Maschinendaten neu
starten wollen.
Die Maschine fährt herunter und wird anschließend sofort wieder hochgefahren.

4.4 Problembehandlung

4.4.1 Unerwartetes Beenden von SinuTrain
In bestimmten Situationen erzwingt das Betriebssystem das Beenden aller laufenden
Programme, z. B.:

● Beim Abmelden des aktuellen Benutzers.

● Beim Neustart des Computers nach Updates.

Falls in diesem Moment SinuTrain läuft und eine Maschine gestartet wurde, werden
die Daten der gestarteten Maschine nur teilweise gesichert und SinuTrain beendet.

Gesicherte Daten

ACHTUNG
Datenverlust
Da SinuTrain schnellstmöglich vom Betriebssystem beendet werden muss, werden
nur die NCK-Daten der gestarteten Maschine gesichert. Änderungen an den HMI-
Daten werden nicht gespeichert.
Um alle Daten zu sichern, fahren Sie regelmäßig die Maschine herunter.

Sicherungsdaten: Keine Sicherungsdaten:
· NCK-Daten · Sämtliche neu hinzugekommene

Anwenderdaten im HMI-Verzeichnis
· Geänderte HMI-Einstellungen z. B.

die HMI-Sprache

Wiederherstellung der Daten

Die NCK-Daten der betroffenen Maschine werden automatisch wiederhergestellt,
sobald sich der betroffene Benutzer erneut anmeldet, SinuTrain aufruft und die
Maschine startet.

Die gewünschten HMI-Einstellungen müssen manuell geändert werden.

CLASES PARTICULARES, TUTORÍAS TÉCNICAS ONLINE
LLAMA O ENVÍA WHATSAPP: 689 45 44 70

- - -
ONLINE PRIVATE LESSONS FOR SCIENCE STUDENTS
CALL OR WHATSAPP:689 45 44 70

www.cartagena99.com no se hace responsable de la información contenida en el presente documento en virtud al
Artículo 17.1 de la Ley de Servicios de la Sociedad de la Información y de Comercio Electrónico, de 11 de julio de 2002.
Si la información contenida en el documento es ilícita o lesiona bienes o derechos de un tercero háganoslo saber y será retirada.



SinuTrain for SINUMERIK Operate

Training und Programmierung
38 A5E38756522, 07/2016

4.4.2 SinuTrain for SINUMERIK Operate Trace
Das Programm SinuTrain for SINUMERIK Operate Trace  bietet die Möglichkeit, eine
Protokollierung der nächsten SinuTrain-Sitzung zu starten. Dabei werden alle
Ereignisse, Abläufe und Meldungen aufgezeichnet, die für eine Fehlersuche relevant
sind.

Start des Programms

Das Programm SinuTrain for SINUMERIK Operate Trace wird im
Programmverzeichnis von SinuTrain installiert. Der Standardpfad lautet C:\Program
Files (x86)\Siemens\SinuTrain\SinuTrain Workbench\ . Starten Sie das Programm
durch Doppelklick.

Um die Aufzeichnungen zu starten, klicken Sie auf die Schaltfläche "Aktivieren".

Hinweis
Das Aktivieren und Deaktivieren der Funktion ist nur möglich, wenn SinuTrain vorher
beendet wurde.
Die Einstellungen für die Traces können nur geändert werden, wenn die Funktion
deaktiviert ist.

Ablage der Daten

Nach dem Start von SinuTrain for SINUMERIK Operate Trace können Sie das
Ablageverzeichnis für die Trace-Dateien frei wählen.

Mit jedem neuen Start von SinuTrain wird dort ein Unterverzeichnis mit Datums- und
Zeitangabe im Namen angelegt, in das die aktuelle Trace-Datei gespeichert wird.

Zur Klärung eines Problems kann es hilfreich sein, mehrere Trace-Dateien
gleichzeitig zu analysieren. Deshalb ist die Anzahl der gespeicherten Protokolle frei
wählbar, aber auf maximal 20 Dateien begrenzt.
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Hinweis
Änderungen an den Einstellungen zur Ablage der Trace-Dateien werden erst beim
nächsten Start von SinuTrain wirksam.
Das bedeutet, wenn eine bereits existierende Trace-Historie reduziert wird, bleibt die
Anzahl der Traces solange bestehen bis SinuTrain for SINUMERIK Operate Trace
aktiviert und SinuTrain gestartet wurde.

Beispiel

Es existieren bereits 12 Unterverzeichnisse mit Trace-Dateien. Die Anzahl der
Traces wird auf 3 reduziert. SinuTrain for SINUMERIK Operate Trace wird aktiviert
und SinuTrain gestartet.

Dabei werden die 10 ältesten Trace-Dateien gelöscht und ein neues
Unterverzeichnis angelegt. Nach Beendigung von SinuTrain existieren genau 3
Traces.

Systemdaten

In bestimmten Situationen benötigt die Hotline für die Fehleranalyse die Systemdaten
des Anwender-PCs, wie zum Beispiel die Prozessorleistung oder die
Arbeitsspeicherauslastung. Dafür ist die Schaltfläche „Systemdaten anzeigen“
vorgesehen.

4.4.3 Trace erstellen
Sollten beim Arbeiten mit SinuTrain Probleme auftreten, haben Sie die Möglichkeit,
einen Trace zu erstellen.

Aktivieren Sie dazu das Tool "SinuTrain for SINUMERIK Operate Trace (Seite 38)".
Das Tool protokolliert dann alle Aktionen und Ereignisse der nächsten SinuTrain-
Sitzung in eine Textdatei, die Sie zur Analyse an die Hotline senden.

Randbedingungen

Das Trace-Tool kann nur aktiviert oder deaktiviert werden, wenn SinuTrain nicht
läuft.
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Vorgehensweise

1. Stellen Sie sicher, dass SinuTrain beendet wurde.

2. Navigieren Sie zum Installationsverzeichnis von SinuTrain (Standardpfad:
"C:\Programme (x86)\SIEMENS\SinuTrain") und öffnen Sie den Ordner
"SinuTrain Workbench".

3. Doppelklicken Sie auf die Datei "sinutraintrace.exe".
Das Tool "SinuTrain for SINUMERIK Operate Trace" wird geöffnet.
In "Ablagepfad" wird der Pfad zu dem Ordner angezeigt, in dem die Trace-Datei
abgelegt wird.

Hinweis
Ablageort ändern
Klicken Sie auf die Schaltfläche "..." und navigieren Sie zu dem gewünschten
Ablageort, klicken Sie auf die Schaltfläche "Neuen Ordner erstellen", vergeben
Sie einen Namen und klicken Sie auf die Schaltfläche "OK".
Der ausgewählte Ablagepfad wird gespeichert.

4. Klicken Sie auf die Schaltfläche "Aktivieren".

5. Starten Sie SinuTrain und reproduzieren Sie die Schritte, die zu dem Problem
führten.

6. Wechseln Sie zum Trace-Tool und klicken auf die Schaltfläche "Trace-Ordner"
öffnen.

7. Kopieren Sie die im Ordner abgelegte Datei "sitrace.txt" und senden Sie diese
per Mail an den Technical Support (Seite 3) zur Analyse.

8. Wenn Sie das Trace-Tool deaktivieren wollen, müssen Sie SinuTrain vorher
wieder beenden.

Hinweis
Informationen zu Systemdaten
Sie haben die Möglichkeit sich mit Hilfe der Schaltfläche "Systemdaten anzeigen"
Informationen zum Betriebssystem, zu den Prozessoren und zur aktuellen
Speicherbelegung anzeigen zu lassen. Über die Schaltfläche "Systemdaten in die
Zwischenablage kopieren" speichern Sie diese Daten zur Weiterleitung an die
Hotline in die Zwischenablage.
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5 Ergänzende Dokumentationen

5.1 Bedienhandbücher und Trainingsanleitungen
Bei der Bedienung in SinuTrain haben Sie die Möglichkeit, die kontextsensitive
Online-Hilfe von SINUMERIK Operate über die HELP-Taste zu verwenden.

Zusätzlich stehen ergänzende und weiterführende Bedienhandbücher und
Trainingsunterlagen in sechs Sprachen (Deutsch, Englisch, Französisch, Italienisch,
Spanisch, Chinesisch vereinfacht) zur Verfügung.

Hinweis
Ist eine fremdsprachige Version eines Dokumentes nicht verfügbar, steht Ihnen
alternativ die englische Ausgabe zur Verfügung.

Bedienanleitungen und Trainingsunterlagen

● Einfacher Fräsen mit ShopMill
– Grundlagen zu Fräsen
– Handhabung des Programms
– Schritt-für-Schritt-Anleitungen zur Programmierung und Bearbeitung

verschiedener Beispiele

● Einfacher Drehen mit ShopTurn
– Grundlagen zu Drehen
– Handhabung des Programms
– Schritt-für-Schritt-Anleitungen zur Programmierung und Bearbeitung

verschiedener Beispiele

● Fräsen
– Ausführliches Bedienhandbuch für SINUMERIK Operate auf SINUMERIK

840D sl/828D mit der Ausprägung Fräsen.

● Drehen
– Ausführliches Bedienhandbuch für SINUMERIK Operate auf SINUMERIK

840D sl/828D mit der Ausprägung Drehen.

● Universal
– Ausführliches Bedienhandbuch für SINUMERIK Operate auf SINUMERIK

840D sl mit der Ausprägung Universal (ohne Zyklenbeschreibungen).
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● Grundfunktionen
– Ausführliches Funktionshandbuch mit Beschreibung von SINUMERIK

Grundfunktionen.

● Programmierhandbuch Grundlagen
– Programmierhandbuch für Anwender mit Grundkenntnissen in Bohr-, Fräs-

und Drehbearbeitungen.
– Einfache Programmierbeispiele, die auch nach DIN 66025 bekannte Befehle

und Anweisungen erläutert.

● Programmierhandbuch Arbeitsvorbereitung
– Ausführliches Programmierhandbuch mit Beschreibung sämtlicher Parameter.

● Funktionshandbuch ISO Dialekte
– Beschreibung für die Inbetriebnahme und Abarbeitungsmöglichkeit von

Teileprogrammen externer CNC-Systeme.

● Programmierhandbuch ISO Fräsen
– Ausführliche Beschreibung der Besonderheiten der Programmierung im ISO-

Mode für die Ausprägung Fräsen.
Programmierhandbuch ISO Drehen
– Ausführliche Beschreibung der Besonderheiten der Programmierung im ISO-

Mode für die Ausprägung Drehen.
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A Anhang

A.1 Menübefehle
Zur Bedienung von SinuTrain stehen folgende Menübefehle zur Verfügung:

Menü Menübefehle Funktion
Datei Neu aus einer Vorlage... Wechselt in das Fenster "Neue

Maschine erstellen - Vorlage
verwenden", zur Anlage einer neuen
Maschine.

aus einem IBN-
Archiv...

Wechselt in das Fenster "Neue
Maschine erstellen - IBN-Archiv
einlesen", zur Anlage einer neuen
Maschine.

Kopieren und einfügen Kopiert die in der Maschinenübersicht
selektierte Maschine und fügt sie der
Liste der Maschinen hinzu.
Über den Menübefehl Maschine >
Einstellungen... oder "Einstellungen..."
im Kontextmenü ändern Sie
anschließend die Eigenschaften der
kopierten Maschine.

Löschen Löscht die ausgewählte SinuTrain-
Maschine.

Importieren… Wechselt in das Fenster "Neue
Maschine erstellen - Maschine
importieren", um abgelegte und
gesicherte Maschinen in die
Maschinenübersicht zu übernehmen.
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Menü Menübefehle Funktion
Exportieren… Öffnet den Dialog "Speichern unter", um

Maschinenkonfigurationen aus der
Maschinenübersicht abzulegen und zu
sichern.

Druckeinstellungen... Wechselt in das Fenster
"Druckeinstellungen".
Hier legen Sie Seitenränder und
Druckbereich fest und wählen die
Darstellungsform der NC-Programme
für den Druck.

Drucken... Druckt Programme entsprechend der
Festlegungen in "Druckeinstellungen"
aus dem Editor des SINUMERIK
Operate.
Hinweis:
Nur bei gestarteter Maschine aktiv.

Beenden Beendet SinuTrain for SINUMERIK
Operate.

Maschine Starten Startet die in der Maschinenübersicht
gewählte Maschinenkonfiguration.

Neu starten Fährt die SinuTrain-Maschine herunter
und startet sie anschließend wieder
automatisch.

Herunterfahren Fährt die SinuTrain-Maschine herunter.
Die Maschinenübersicht bleibt geöffnet.

Einstellungen… Wechselt in das Fenster "Maschine
bearbeiten", um Maschinennamen,
Beschreibung, Sprache und
Maschinenbild sowie die Auflösung der
SINUMERIK Operate Oberfläche zu
ändern.

Extras HMI Zusatzsprachen
installieren...

Wechselt in das Fenster "HMI
Zusatzsprachen installieren", um
zusätzliche verfügbare Sprachen für
SINUMERIK Operate zu installieren.
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Menü Menübefehle Funktion
Optionen... Wechselt in das Fenster "Optionen", um

folgende Einstellungen vorzunehmen:
· Wahl der Sprache der SinuTrain

Oberfläche
· Aktivieren bzw. deaktivieren von

Hinweismeldungen in SinuTrain for
SINUMERIK Operate (z.B. Hinweis
auf möglichen Datenverlust beim
Löschen einer SinuTrain-Maschine)

Fenster In Einzelfenster aufteilen Teilt das Fenster der
Maschinensimulation in 3 einzeln
verschiebbare Fenster:
· Bedienoberfläche SINUMERIK

Operate
· Bedienelemente einer Bedientafel
· Maschinensteuertafel mit Vorschub-

und Spindeloverride
Hinweis:
Nur bei gestarteter Maschine aktiv.

Hilfe Hilfe zu SinuTrain... Öffnet die Online-Hilfe für SinuTrain for
SINUMERIK Operate.

Hilfe zu SINUMERIK CNC-
SW

Öffnet die Online-Hilfe für die
relaesespezifischen Informationen.
Die Untermenüs sind abhängig von den
installierten CNC-Softwareständen.

Info... Wechselt in das Fenster "Über
SinuTrain for SINUMERIK Operate", in
dem Sie folgende Informationen
erhalten:
· Produktversion des installierten

SinuTrain for SINUMERIK Operate
· Im Bereich "Installierte SINUMERIK

CNC-SW Pakete" Angabe der
Versionen aller CNC- Software
Pakete
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A.2 Kontextmenü
In der Maschinenübersicht steht Ihnen für jede Maschinenkachel ein Kontextmenü
mit folgenden Befehlen zur Verfügung:
Menübefehle Funktion
Starten Startet die in der Maschinenübersicht gewählte

Maschinenkonfiguration.
Exportieren… Öffnet den Dialog "Speichern unter", um

Maschinenkonfigurationen aus der Maschinenübersicht zu
exportieren.

Kopieren und einfügen Kopiert die in der Maschinenübersicht selektierte
Maschine und fügt Sie der Liste der Maschinen hinzu.
Über den Menübefehl Maschine > Einstellungen... oder
"Einstellungen..." im Kontextmenü ändern Sie
anschließend die Eigenschaften der kopierten Maschine.

Löschen Löscht die ausgewählte SinuTrain-Maschine.
Einstellungen… Wechselt in das Fenster "Maschine bearbeiten", um

Maschinennamen, Beschreibung, Sprache und
Maschinenbild sowie die Auflösung der SINUMERIK
Operate Oberfläche zu ändern.
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A.3 Bedienung mit PC-Standardtastatur
Zur Bedienung von SinuTrain SINUMERIK Operate stehen folgende Tasten und
Tastenkombinationen zur Verfügung.
PC-Tastatur Funktion
<F1> ... <F8> Horizontale Softkeys 1 bis 8
Shift + <F1> ... <F8> Vertikale Softkeys 1 bis 8
<F9>

Shift + <F9>

<F10>

Shift + <F10>

<F11>

<F12>

<Bild ↑>

<Bild ↓>

<Enter>
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PC-Tastatur Funktion
<Einfg>

Ziffernblock <5>

<Esc>

<Strg> + <Alt> + <Shift> +
<1>

<Strg> + <Alt> + <Shift> +
<2>

Die laufende SinuTrain-Maschine wird
heruntergefahren.

<Strg> + <Alt> + <Shift> +
<3>

<Strg> + <Alt> + <Shift> +
<4>

<Strg> + <Alt> + <Shift> +
<5>

<Strg> + <Alt> + <Shift> +
<6>

<Strg> + <Alt> + <Shift> +
<7>

<Strg> + <Alt> + <Shift> +
<8>
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SINUMERIK
SinuTrain for SINUMERIK Operate
Training and Programming
Compact User Manual

Preface
Welcome to the SinuTrain for SINUMERIK Operate - Training and programming at
the PC.

The training software SinuTrain for SINUMERIK Operate teaches you how to operate
and program the 840D sl control system / 828D.

SinuTrain for SINUMERIK Operate - Training and programming

This documentation supports you step-by-step for the following tasks:

● Installing the training software from DVD

● Transferring the license

● Starting the program

● Selecting the machine tool

● Starting simulation

What groups does SinuTrain for SINUMERIK Operate address?

SinuTrain for SINUMERIK Operate is designed for basic and further training of the
following target groups:

● First time users, users changing over from a different system

● Training managers, trainers

● Sales personnel for customer presentations

● CNC programmer for work preparation
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Information

Information on the following topics is available under the link Technical Sinumerik
documentation (https://support.industry.siemens.com/cs/ww/en/view/108464614):

● Downloading documentation
Links to more information for downloading files from the Siemens Industry Online
Support Portal.

● Compile customized documentation
MySupport/ Documentation provides you with a range of features for generating
your own machine documentation.
See also MySupport/ Documentation
(https://support.industry.siemens.com/My/ww/en/documentation)

● Ordering documentation
Here you can find an up-to-date overview of publications.

● Training and FAQs
Information on our range of training courses and FAQs (frequently asked
questions) is available via the page navigation.

Legal basics

This software (SinuTrain™) is used to generate and simulate NC programs on a PC
based on the DIN 66025 programming language as well as the ShopMill, ShopTurn
and language commands, type Sinumerik™ 828D and 840D sl. The programs
generated with the software must only be used on machine tools for production if the
software (SinuTrain/JobShop), on which the generated program should run, has
been adapted to Sinumerik.

This adaptation must be professionally performed by authorized personnel, e.g. by
Siemens, by machine tool OEMs or by dealers; when carrying out any adaptation
work, the specifications of Siemens and the machine tool OEM must always be
carefully observed. Otherwise, the machine tool could malfunction.

Otherwise, for customers in Germany, the "Allgemeinen Bedingungen zur
Überlassung von Software für Automatisierungs- und Antriebstechnik an
Lizenznehmer mit Sitz in Deutschland" applies for the software and for customers
outside Germany "General License Conditions for Software Products for Automation
and Drives for Customers with a Seat or Registered Office outside of Germany".
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Technical Support

If you have any technical questions, please contact our hotline:
Europe / Africa

Phone +49 (0)911 895 7222
Fax +49 (0)911 895 7223
0.14 €/min from the German landline; cell phone charges may vary.
Internet https://www.siemens.com/automation/support-request

Americas
Phone +1 423 262 2522
Fax +1 423 262 2200
E-mail mailto:techsupport.sea@siemens.com

Asia / Pacific
Phone +86 1064 757 575
Fax +86 1064 747 474
E-mail mailto:support.asia.automation@siemens.com

Note
Country-specific telephone numbers for technical support are provided under the
following Internet address:
https://www.automation.siemens.com/partner

Questions about the manual

If you have any queries (suggestions, corrections) in relation to this documentation,
please fax or e-mail us:
Fax +49 9131- 98 2176
E-mail mailto:docu.motioncontrol@siemens.com

Internet address

http://www.cnc4you.siemens.com
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1 Overview
The SinuTrain for SINUMERIK Operate training software (called SinuTrain in the
following) simulates a SINUMERIK 840D sl with the SINUMERIK Operate user
interface on your PC.

Note
License
You require a license to start a machine using the full functional scope.

True to original representation and behavior

As a result of the true to original representation of the operating panel front, machine
control panel and user interface, SinuTrain facilitates real operation.

● SinuTrain includes a machine control panel with specific functions of a real
control panel (e.g. CYCLE START, operating mode etc.).

● SinuTrain includes an operator panel, with which all of the specific functions of a
real operator panel can be used (hotkey etc.).

● The user interface corresponds to the original interface of SINUMERIK Operate.

● The simulation behaves in precisely the same way as a real control.

Saving and printing NC programs

SinuTrain offers the option of saving the NC programs that you have created (G code
and machining step programs).

You also have the option of printing out a program which is open in the user interface
of SINUMERIK Operate.
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2 Licensing using the Automation License
Manager

You require a valid license key to start a machine with the full functional scope in
SinuTrain. It is an integral part of SinuTrain for SINUMERIK Operate, and is supplied
on a USB stick.

A license is not required to use SinuTrain.

All operating areas and functions can be operated.

License

Additional functions are available with a license (Page 58).

Note
Information on the license
More detailed information on licenses is available in the readme.

Transferring the license using the Automation License Manager

Precondition: USB stick with the license to be transferred.

1. Start the Automation License Manager via the icon or from the Start menu.
The Automation License Manager opens.

2. Insert the USB stick.
The USB stick is displayed under "Own computer".

3. Select the entry "Removable Disk" on the lefthand side.
On the right-hand side you can see the available licenses on the USB stick.

4. Transfer the license by dragging and dropping it onto the local hard disk.
- OR -
Select “Transfer" in the shortcut menu of the license.

5. In the window that opens, select where the license should be transferred to
(target).
After the license has been transferred, this is shown on the target drive.
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3 License model
The usage and scope of functions provided by the various template machines
depends on the availability of a license.

DEMO machines

● DEMO machines are preconfigured machines that cannot be changed.

● You do not require a license for DEMO machines.

● You can start and operate the machines.

● You can, for example, transfer workpieces and part programs to the machine for
program simulation and customization, and then from the machine for further use
on CNCs.

● Selected functions are not available. You can find additional information in the
help for the CNC software.

Template machines / imported machines / machines created from the start-up
archive

● You can start and operate all machines. This makes it possible for you to try all
SINUMERIK functions.

● All machines have the full functional scope of SINUMERIK Operate.

● License
– Without license

The transfer of workpieces and part programs to or from the machine is not
possible.

– With license
The transfer of workpieces and part programs to or from the machine is
possible.

Note
Importing a license subsequently
If you import a license when the machine has already been started, this causes a
restart.
Only then is it possible to use the machine without restrictions.

Exporting and importing machines / printing part programs

You generally require a license for the "Import" and "Export" functions of machines as
well as for the printing of part programs.
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4 SinuTrain for SINUMERIK Operate

4.1 Installing / uninstalling SinuTrain

4.1.1 System requirements
Hardware

Processor: 2 GHz (single core)

RAM: 4 GB

Hard disk:

● 3.3 GB for complete installation with all languages

● 1.2 GB for minimal installation (language English)

DVD drive: For installation using DVD data storage medium

Graphic card:

● DirectX 9 or higher with WDDM 1.0 driver

● minimum resolution 800x600 pixel

USB interface

Mouse, keyboard

Operating systems

● Windows 7 (32-bit and 64-bit, Starter, Web Edition and Embedded are not
supported)

● Windows 8.1

Software

Adobe Acrobat Reader®
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4.1.2 Installing SinuTrain
The SinuTrain for SINUMERIK Operate software product comprises various software
components that in some cases have their own setup (e.g. Automation License
Manager).

Precondition

You require a license key to start and work with machines that have been created.
This key must be transferred to the PC before starting a machine for the first time.
When installing SinuTrain, an additional program is installed for this purpose – the
Automation License Manager. The license key is transferred to the PC using the
Automation License Manager.

Procedure

1. Double-click the "setup.exe" in the root directory of the DVD.
When the user account control is activated, after double-clicking the "setup.exe",
a system prompt appears. With this prompt, you agree that setup can make
changes to your system (this prompt comes from Windows and is not a
component created by Siemens). Confirm this dialog and continue with the
installation.

2. Select the setup language and click the "Next >" button.

3. Read the notes on the installation and usage of the program and click the "Next
>" button.

4. Click the "Readme" button to read the readme text with the product notes, then
close the readme file and click the "Next >" button.

5. Read the license agreement and then activate the checkbox to accept the
licensing agreement and the safety instructions and click the "Next >" button.

6. Select the languages in which you wish to install SinuTrain for SINUMERIK
Operate .
The selected languages are available in SinuTrain as well as SINUMERIK
Operate.

7. In the "Programs" window, activate the required checkbox and click the "Next>"
button.
If you want to change the installation path of the individual products, select the
specific product, click the "Browse" button and select the required folder.
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Note
Before installing SinuTrain, under certain circumstances, system updates are
automatically installed, which may make it necessary to restart the computer.
Setup is automatically continued after the PC restarts.

The installation of SinuTrain and Automation License Manager then starts.
You receive an appropriate message after completing the installation of
SinuTrain.

8. Click the "Exit" button.
SinuTrain and the Automation License Manager are ready.

Note
User account control system
When querying the user account control, if "unknown" is specified as the supplier,
respond with No and contact the hotline.
All Siemens products released have a certificate, where Siemens AG is always
specified when querying the supplier.

Note
Click the "Cancel" button to exit the installation.

Note
We recommend that the installation is not started from a network drive. This is
because problems can be encountered as a result of possible necessary system
updates.

4.1.3 Uninstalling SinuTrain

Procedure

1. In the Windows menu, select Start > Control Panel.

2. Double-click "Programs and functions" in the list of the Control Panel (Windows
7).

3. In the software list, select "SinuTrain Workbench 1.2" and click the "Uninstall"
button.

4. In the software list, select the installed versions of "SinuTrain SINUMERIK CNC-
SW" and click the "Uninstall" button.
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4.2 Operating SinuTrain

4.2.1 This is how SinuTrain functions

Precondition

SinuTrain for SINUMERIK Operate has been installed.

General sequence

● Selecting a language
Select the required language for SinuTrain and SINUMERIK Operate at the first
start.

● Starting SinuTrain
After confirming the Terms of Use, SinuTrain opens with the machine overview.

● Creating a machine
Create a machine in the machine overview.
First select a machine of the required type using templates.
Then specify the name and brief description of the machine, if required, select
your own machine image for the machine overview and specify the resolution and
language of the machine simulation in the SINUMERIK Operate user interface.

● Starting a machine
The machine simulation opens with operator panel and SINUMERIK Operate
user interface, machine control panel with feedrate and spindle override and CNC
keyboard.

● Simulating a machine
You can now operate the simulated machine just like a real machine and
generate programs, for example.
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4.2.2 Machine overview
In the machine overview, you create machines and parameterize and manage the
machine configurations with which you train.

① Functions page with options for the creation of machine configurations
② SinuTrain menu
③ Machine overview with all created machines
④ Information page with a description of the selected machine configuration
⑤ Created machine configuration with machine name and CNC software version
⑥ Selected machine configuration
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See also

Menu commands (Page 89)

Context menu (Page 92)

Overview (Page 69)

Creating a machine from a template (Page 70)

Copying and configuring a machine (Page 72)

Importing a machine (Page 72)

Creating a machine from the start-up archive (Page 74)

4.2.3 Screen layout of the machine simulation

User interface of SinuTrain

① SinuTrain menu
② SINUMERIK Operate user interface
③ Operator controls of an operator panel
④ Machine control panel with feedrate and spindle override
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See also

Menu commands (Page 89)

4.2.4 Installing languages

4.2.4.1 Installing additional languages for Sinutrain
Select the required language when installing SinuTrain for SINUMERIK Operate. The
user interface of SINUMERIK Operate is also installed with the selected language.

The following standard languages are available for selection during the installation:
English, German, French, Italian, Spanish and simplified Chinese.

Subsequent installation of SinuTrain languages

If you have not selected one of the standard languages during the installation of
SinuTrain, you can install the required language subsequently by performing the
setup (repair installation) again. SINUMERIK Operate is then also available in the
language.

4.2.4.2 Installing additional languages for SINUMERIK Operate
You can install further languages for the SINUMERIK Operate user interface.

Installing additional languages

Additional language packages are offered for download at the following Internet
address:

http://www.cnc4you.siemens.com (http://www.cnc4you.siemens.com)

Procedure

1. Select the Tools > Install additional HMI languages... menu command.
The "Install additional HMI languages" window opens.

2. Click the "..." button and navigate in the "Open" dialog to the storage location of
the language packages.
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3. Select the required language file (*.slf) and click the "Open" button.
You return to the "Install additional HMI languages" window.
The storage path has been entered. The selected language is displayed and
marked with a flag icon. In addition, the version of the SINUMERIK Operate
language package and the control type are displayed.

4. If necessary, select the CNC software release for which the language package
should be installed.

5. Click the "Install" button.
A progress bar shows the installation process.
You receive a message after successful installation.

6. Click the "OK" button to complete the installation.

Note
After the message regarding successful installation, you have the option of disabling
future installations of language packages. To do this, activate the "Do not display this
note again" checkbox.
Select the Tools > Options menu command and activate the "Report completion of
the language installation" checkbox in the "Options" window in order to switch the
message on again for future installations.

4.2.5 Changing the SinuTrain language
You have the option of changing over the language (German, English, French,
Spanish, Italian, Chinese simplified) of the SinuTrain user interface.

All languages installed during the setup or those subsequently installed can be
selected.

Note
Subsequent installation of SinuTrain languages
If you have not selected one of the standard languages during the installation of
SinuTrain, you can install the required language subsequently by performing the
setup (repair installation) again.

Procedure

1. Select the Tools > Options menu command.

2. Select the required language in the "Language of the SinuTrain user interface"
drop-down list and click "OK".
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Note
Changing the language of SINUMERIK Operate
In SINUMERIK Operate you can change the language of the SINUMERIK Operate
user interface using the key combination <CTRL + L> or in the "Commissioning"
operating area, using the "Change language" softkey.

See also

Installing additional languages for SINUMERIK Operate (Page 65)

4.3 Working with SinuTrain

4.3.1 Starting and exiting SinuTrain

Starting SinuTrain

1. Select the Programs > SinuTrain for SINUMERIK Operate  > SinuTrain menu
command.
- OR -
Double-click the SinuTrain icon on your desktop.

At the first start, the dialog for the selection of the language for the SinuTrain user
interface and SINUMERIK Operate opens.

2. Select the required language and click "Next".
Note: The languages are available that you selected during the installation of
SinuTrain.
The Terms of Use for SinuTrain for SINUMERIK Operate open.
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3. Click "OK" to start the program.
The machine overview opens.

Note
You can deactivate the Terms of Use for future program starts. To do this, activate
the "Do not display this note again" checkbox.
Select the Extras > Options menu command and activate the "Display Terms of Use
at program start" checkbox in the "Options" window in order to switch the message
on again for future starts.

Exiting SinuTrain

● Select the File > Exit menu command.
SinuTrain closes.

See also
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4.3.2 Creating a machine

4.3.2.1 Overview
You have the following options when creating a machine:

● Creating a machine from a template (Page 70)
The standard configurations supplied for lathes and milling machines form the
basis.

● Copying and configuring a machine (Page 72)
The basis is a machine configuration that you created, which already exists in the
machine overview.

● Importing a machine (Page 72)
The basis is an exported machine configuration, which you import and modify.

● Creating a machine from the start-up archive (Page 74)
The basis is a start-up archive (*.arc).
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4.3.2.2 Creating a machine from a template

Requirement

SinuTrain has been started and the machine overview is open.

Creating a machine from a template

1. Click the "Use template" option in the "Create new machine" functions page.

- OR -
Select the File > New > From a template... menu command.
The "Create new machine - Use template" dialog opens.

Note
Various template machines are available depending on the available SINUMERIK
version.

2. Open the "Machine type" drop-down list and select the required template.
You can select the required CNC software (e.g. 4.7) in the data tree that opens
for each system (e.g. 840D sl).
After selection, the system and software version of the selected machine is
displayed in the "Created with CNC SW" field.

3. In the "Machine name" entry field, enter a name for the machine (e.g. My
machine).

4. If required, enter a short description in the "Description" entry field.
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5. Select the resolution for the machine user interface (e.g. 1024 x 768).

6. Select the language for the machine user interface (e.g. English).

7. If you want to use your own machine image for the machine display, click the "..."
button next to the "Import image" field, navigate in the "Open" dialog to the
storage location of the graphic (*.png,*.jpg,*.bmp) and click "OK".
You return to the "Create new machine - Use template" window. The storage path
is displayed.

8. Click the "Create" button.

Note
If a machine with this name already exists, a corresponding message is
displayed. Click "OK" and enter a new machine name.

The machine configuration for the SINUMERIK 840D sl is inserted in the
overview.
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4.3.2.3 Copying and configuring a machine

Requirement

● SinuTrain has been started and the machine overview is open.

● Machines have been created.

Creating a new machine configuration

1. In the machine overview, select the machine configuration that you want to copy
and use for another machine.

2. Select the File > Copy and Paste menu command.
- OR -
Right-click and select “Copy and Paste" from the shortcut menu.
The machine is added to the machine overview and identified by a number in the
machine name.

3. Then select the Machine > Settings... menu command for the copied machine.
- OR -
Right-click and select "Settings..." from the shortcut menu.
The "Edit machine" dialog opens.

4. Enter the desired changes (e.g. machine name, resolution, language, machine
image) and click "Save and close".

See also

Changing machine settings (Page 77)

4.3.2.4 Importing a machine

Requirements

● You have a license.

● SinuTrain has been started and the machine overview is open.

● You have exported machine configurations as backup or as starting point for
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Note
Different SINUMERIK CNC system software versions
The SINUMERIK CNC system software version of the file to be imported is available
with SinuTrain for SINUMERIK Operate . With different versions, manual changes
must be made subsequently in accordance with the NC upgrade instructions.

Importing a machine

1. Click the "Import machine" option in the "Create new machine" functions page.

- OR -
Select the File > Import... menu command.
The "Create new machine - Import machine" window opens.

2. Click the "..." button next to the "Selected file" field and navigate in the "Open"
dialog to the storage location of the exported configurations.

3. Select the required machine configuration file (*.set) and click the "Open" button.
You return to the "Create new machine - Import" window.
– The storage path is shown in the "Selected file" field.
– The "Created with CNC SW" field shows the SINUMERIK CNC software

version and the system (e.g. 840D sl) with which the machine configuration
has been created.

4. If you have installed several versions of the CNC software, in field "Accept in",
select for which software release the machine should be created.
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5. Change the required settings as needed (e.g. machine name, description, etc.)
and import your own machine image if applicable.

Note
Note that machines with identical names are not permitted in the machine
overview.
Always change the machine name in the "Create new machine - Import" window
even if you do not want to change the type of machine.

6. If you want to use the selected configuration as a template for other machines in
the future, check the checkbox "Accept machine in the list of template machines".

7. Click the "Create" button.

Note
Warning notices and messages
If problems occur when importing the machine configuration, a window opens
with the appropriate messages. Elements (e.g. cycles) that have not been
imported error-free are listed with the appropriate descriptions.
Click "OK" to close the window.

You return to the machine overview and the machine is created.

4.3.2.5 Creating a machine from the start-up archive
Note the following conditions when creating machines from start-up archives.

● SINUMERIK CNC system software version and SinuTrain for SINUMERIK
Operateversion must match, otherwise it may not be possible to adapt the
machine configuration.

Note
Manual adaptation of the machine configuration
If an adaptation is not possible, manual changes must be made subsequently in
accordance with the NC upgrade instructions.
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● If data is contained which is not suitable or not required for use in SinuTrain (e.g.
for the PLC or drives), the machine configuration is adapted.

Note
An overview of all adapted machine data can be found in the online help for the
CNC software. Select the menu command Help > Help for SINUMERIK CNC SW
> and the corresponding software version.

● The setup archive must contain all NC data.

● Start-up archives from powerline systems and HMI-Advanced/Embedded cannot
be used.

Requirement

● You have a license.

● SinuTrain has been started and the machine overview is open.

Creating a machine from a setup archive

1. Click the "Read setup archive" option in the "Create new machine" functions
page.

- OR -
Select the File > New > From a setup archive... menu command.
The "Create new machine - Read setup archive" dialog opens.
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2. Click the "..." button next to the "Selected file" field and navigate in the "Open"
dialog to the storage location of the required archive file (*.arc), select the file and
click "Open".
A message informs you that the archive is being checked.
You return to the dialog and the selected file is displayed with the directory path.
The control type and software version of SINUMERIK Operate are also displayed.

Note
Notice messages
After the setup archive is imported, you will get a window with informational
messages, which point out possible errors and problems.
You have the capability of copying the figures entered in the "Description" column
via the button and to then send them to the hotline (Page 51) for analysis.

3. If you have installed several versions of the CNC software, in field "Accept in",
select for which software release the machine should be created.

4. Enter the required specifications for the machine configuration (name and
description) in the corresponding entry fields, if required, import your own
machine image and select the resolution (e.g. 1024 x 768) and language (e.g.
English) of the machine user interface.

5. If you want to use the selected configuration as a template for other machines in
the future, check the checkbox "Accept machine in the list of template machines".

6. Click the "Create" button.

Note
If a machine with this name already exists, a corresponding message is
displayed. Click "OK" and enter a new machine name.

The created machine configuration is inserted in the overview, and the system
(e.g. 840D sl) and the SINUMERIK CNC software version are displayed.
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4.3.3 Changing machine settings
You can change the following settings for a machine:

● General
– Machine name
– Description

● Language
Machine interface language (German, English, French, Spanish, Italian, simplified
Chinese). Only the languages selected during installation are available for
selection.
If you have subsequently installed additional languages, these are also available
for selection.

● Resolution
Resolution of the machine interface
– 640x480
– 800x600
– 1024x768
– 1280x1024

● Importing an image
Your own machine images can be stored in the following formats:
– PNG
– JPG
– BMP

Procedure

1. In the machine overview, select the machine for which you want to change the
settings.

2. Select the Machine > Settings... menu command.
- OR -
Right-click and select "Settings..." from the context menu.
The "Edit machine" dialog opens.
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4.3.4 Exporting a machine configuration
You have the option of exporting machines that you have configured in order to back
them up. The exported machine configurations are available as a starting point for
later machine configurations or as a back-up copy. To do this, import the saved
machine configuration file.

Exported machine configurations allow you to exchange these between two
computers or to subsequently import them into more recent SinuTrain versions.

Requirement

You have a license.

Procedure

1. In the machine overview, select the machine configuration that you want to
export.

2. Select the File -> Export menu command.
- OR -
Right-click and select "Export..." from the context menu.
The "Save as" dialog opens.

3. Navigate to the desired storage location, if required, change the file name and
click "Save".
You receive a message after a successful export.

4. Click "OK" to finish the export.

Note
You can deactivate the message for the successful export. To do this, activate the
"Do not display this note again" checkbox.
Select the Tools > Options menu command and activate the "Report completion of
the machine export" checkbox in the "Options" window in order to switch the
message on again for future exports.
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4.3.5 Deleting a machine
If you do not require a machine configuration any longer, delete it from the machine
overview.

Procedure

1. Select the machine that you want to remove from the Machine configuration list.

2. Select the File > Delete menu command.
- OR -
Right-click and select "Delete" from the context menu.

3. Confirm the message regarding the possible loss of data with "OK" and click in
the subsequent prompt dialog box the "Yes" button to delete the machine.

Note
SinuTrain machine with user data
When deleting a machine, all user data (e.g. NC programs, work offsets, etc.) are
lost. The data associated with a deleted machine cannot be restored.

Note
You have the option of disabling the message regarding data loss for future delete
operations. To do this, activate the "Do not display this note again" checkbox.
Select the Tools > Options menu command and activate the "Inform of possible data
loss before deleting" checkbox in the "Options" window in order to switch the
message on again for future deletions.

4.3.6 Printing-out a program
You can print out the contents of text files (e.g. NC programs) using a printer
configured on the PC (local printer, network printer) directly via SinuTrain from the
SINUMERIK Operate user interface.

You can print G code programs as well as ShopMill and ShopTurn machining step
programs with G code.
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Defining the layout

In the "Print settings" window, you specify the layout for the printing, define the scope
of the NC program that is to be printed and configure the display of the program.
Settings Effect
Margins
(mm) Left: Right:

Here you define the margins of the printout.
Defines the distance between the top,
bottom, right and left margin and the
respective edge of the lines in mm.

Top: Bottom:

Print
area

Everything

Here you define the scope of the program
printout.
Defines that the complete NC program is
printed.

Lines
from: to:

Defines the lines of the NC program that
are to be printed.

Selected range Defines that only the part of the NC
program marked in the editor is to be
printed.

Print programs as text Defines that sequence programs
(ShopMill/ShopTurn) are printed out as G
code.

Print programs with graphical
illustrations

Defines that machining step programs
(ShopMill/ShopTurn) will be printed in the
same way as they appear in the editor.

Print programs with
input screen

Defines that the parameter screens for the
machining steps are also printed out.

Print closed blocks Defines that when using program blocks,
the program sets in the blocks are also
printed.

Requirement
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Procedure
1. In the archive folder of the program manager, select the program

that you wish to print out.

2. Place the cursor on the program and press the "Open" softkey.
The program opens in the editor.

3. Select the File > Print settings... menu command.
4. Enter the distances for the margins in the "Print settings" window,

define the print range and the representation type of the program
and click the "OK" button to confirm your entries.

6. Select the File > Print menu command.
The "Print" dialog box with the activated standard printer opens
(local printer, network printer).

7. Click the "Print" button.
Depending on the print range that has been defined, the complete
program, a certain number of lines of the program or a selected
range of the program is printed.

4.3.7 Starting and shutting down a machine.

Precondition

● Machine configurations are available in the machine overview.

● You need a license to be able to use the entire range of functions. Information on
function restrictions can be found under License model (Page 58).

Starting a machine

The machine overview is open.

1. Select the required machine in the list of machine configurations.

2. Select the Machine > Start menu command.
- OR -
Right-click and select "Start" from the context menu.
- OR -
Click the arrow in the machine configuration.
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The machine simulation opens with operator panel and SINUMERIK Operate
user interface, machine control panel with feedrate and spindle override and CNC
keyboard.

3. You operate SINUMERIK Operate using a mouse or a standard keyboard.

4. When operating SINUMERIK Operate, click the <HELP> key or press key <F12>
to obtain context-sensitive online help for the window and the input screens of
SINUMERIK Operate.

NOTICE
Loss of data when Sinutrain is exited in a non-scheduled fashion
If the operating system forces Sinutrain to shut down (e.g. when the current user is
logging off), then only the NCK data of the currently operating machine is backed
up. Changes to the machine settings and HMI data are lost.
Regularly run down the machine in order to avoid this data loss.
More information is provided in Section Unexpected shutdown of SinuTrain
(Page 83).

Shutting down the machine

● Select the Machine > Shut down menu command, if you wish to exit the actual
machine configuration.
You return to the machine overview.

Restarting the machine

● Select the Machine > Restart menu command, if you wish to restart the actual
machine configuration - for instance, after changing machine data.
The machine shuts down and is then immediately run up again.
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4.4 Problem handling

4.4.1 Unexpected shutdown of SinuTrain
In certain situations, the operating system forces all of the programs running to be
shut down, e.g.:

● When the current user is logging off.

● For a computer warm start after an update.

If SinuTrain is running and a machine was started at this point in time, then the data
associated with the started machine are only partially backed up, and SinuTrain is
exited.

Backed up data

NOTICE
Data loss
As SinuTrain must be exited as quickly as possible by the operating system, only
the NCK data of the started machine are backed up. Changes to the HMI data are
not saved.
To backup all data, you must regularly run down the machine.

Data that is backed up: Data that is not backed up:
· NCK data · All newly added user data in the HMI

directory
· Changed HMI settings, e.g. the HMI

language

Restoring data

The NCK data of the machine involved is automatically restored as soon as the user
involved logs on again, calls SinuTrain and starts the machine.

The required HMI settings must be manually changed.
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4.4.2 SinuTrain for SINUMERIK Operate Trace
The SinuTrain for SINUMERIK Operate Trace  program offers the option of starting a
log of the next SinuTrain session. All events, sequences and messages/signals are
recorded, which are relevant for troubleshooting.

Starting the NC program

The SinuTrain for SINUMERIK Operate Trace program is installed in the program
directory of SinuTrain. The standard path is C:\Program Files
(x86)\Siemens\SinuTrain\SinuTrain Workbench\ . Double click to start the program.

Click on the "Activate" button to start the recording.

Note
You can only activate and deactivate the function if SinuTrain was first exited.
The trace settings can only be changed if the function is deactivated.

Archiving data

After starting SinuTrain for SINUMERIK Operate Trace you can freely select the
archiving directory for the trace files.

Each time that SinuTrain is started, a subdirectory with date and time in the name is
created there, in which the actual trace file is saved.

It can be helpful to analyze several trace files simultaneously when it comes to
clarifying a problem. This is why the number of saved protocols can be freely
selected, however, the number of files is limited to a maximum of 20.
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Note
Changes to the settings to archive trace files only become effective when SinuTrain
is started the next time.
This means that if an already existing trace history is reduced, the number of traces
is kept until SinuTrain for SINUMERIK Operate Trace is activated and SinuTrain was
started.

Example

12 subdirectories with trace files already exist. The number of traces is reduced to 3.
SinuTrain for SINUMERIK Operate Trace is activated, and SinuTrain started.

The 10 oldest trace files are deleted, and a new subdirectory is created. When exiting
SinuTrain precisely 3 traces exist.

System data

In specific situations, the hotline requires the system data of the user PC when
analyzing faults – for example, processor performance or the utilization level of the
work memory. The "Display system data" button is provided for this purpose.

4.4.3 Creating a trace
Should problems occur while working with SinuTrain, you have the capability of
creating a trace.

To do this, activate the "SinuTrain for SINUMERIK Operate Trace (Page 84)" tool.
The tool then logs all of the actions and events of the next SinuTrain session in a text
file, which you then send to the hotline for analysis.

General conditions

The trace tool can only be activated or deactivated when SinuTrain is not running.

Procedure

1. Ensure that SinuTrain is not running.

2. Navigate to the installation directory (default path: "C:\Programs
(x86)\SIEMENS\SinuTrain") and open the "SinuTrain Workbench" folder.
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3. Double-click the file "sinutraintrace.exe".
The tool "SinuTrain for SINUMERIK Operate Trace" is opened.
"Storage path" shows the path to the folder in which the trace file is saved.

Note
Changing the save location
Click on the "..." button and navigate to the desired save location. Click on the
"Create new folder" button, assign a name, and click on the "OK" button.
The selected storage path is saved.

4. Click the "Activate" button.

5. Start SinuTrain and reproduce the steps that led to the problem.

6. Switch to the trace tool and click on the open "Trace folder" button.

7. Copy the file "sitrace.txt" that was saved in the folder and send it via e-mail to
Technical Support (Page 51) for analysis.

8. If you want to deactivate the trace tool, you must first close SinuTrain beforehand.

Note
Information on system data
With the aid of the "Display system data" button, you have the capability of displaying
information about the operating system, the processors, and the current memory
allocation. Using the "Copy system data to the clipboard" button, save this data to the
clipboard for forwarding to the hotline.
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5 Additional documentation

5.1 Operating Manual and training instructions
When using SinuTrain, you have the option of using the context-sensitive online help
of SINUMERIK Operate via the HELP key.

Furthermore, additional and more in depth operating manuals and training
documents are available in six languages (German, English, French, Italian, Spanish,
simplified Chinese).

Note
If a particular foreign language version of a document is not available, then as an
alternative, the English edition is available.

Operating Manuals and Training Documents

● Easy milling with ShopMill
– Milling basics
– Handling the program
– Step-by-step instructions for programming and machining various examples

● Turning made easy with ShopTurn
– Turning basics
– Handling the program
– Step-by-step instructions for programming and machining various examples

● Milling
– Detailed operating manual for SINUMERIK Operate on SINUMERIK 840D

sl/828D, milling version.

● Turning
– Detailed operating manual for SINUMERIK Operate on SINUMERIK 840D

sl/828D, turning version.

● Universal
– Detailed Operating Manual for SINUMERIK Operate on SINUMERIK 840D sl,

Universal version (without cycles description).

● Basic Functions
– Detailed Function Manual with a description of basic SINUMERIK functions.
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● Programming Manual, Fundamentals
– Programming Manual for users with a basic knowledge about drilling, milling

and turning.
– Simple programming examples that also explain commands and operations

according to DIN 66025.

● Programming Manual Advanced
– Detailed Programming Manual with a description of all parameters.

● Function Manual ISO Dialects
– Description for the commissioning and execution option of part programs

belonging to external CNC systems.

● Programming Manual, ISO milling
– Detailed description of the special issues when programming in the ISO

mode, milling version.
Programming Manual, ISO turning
– Detailed description of the special features when programming in the ISO

mode, turning version.
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A Appendix

A.1 Menu commands
The following menu commands are available to operate SinuTrain:

Menu Menu commands Function
File New From a template... Changes to the "Create new machine -

Use template" window to create a new
machine.

From a setup
archive...

Changes to the "Create new machine -
Read setup archive" window to create a
new machine.

Copying and inserting Copies the machine selected in the
machine overview and inserts it in the
list of machines.
You then change the properties of the
copied machine via the Machine >
Settings... menu command or the
"Settings..." command in the shortcut
menu.

Delete Deletes the selected SinuTrain
machine.

Import... Changes to the "Create new machine -
Import machine" window to transfer
stored and saved machines to the
machine overview.
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Menu Menu commands Function
Export... Opens the "Save as" dialog to store and

save machine configurations from the
machine overview.

Print settings... Switches to the "Print settings" window.
Here you define the margins and print
range and select the representation
type of the NC programs for printing.

Print... Prints programs corresponding to what
has been defined in "Print settings" from
the SINUMERIK Operate editor.
Note:
Only active for started machines.

Exit Exits SinuTrain for SINUMERIK
Operate.

Machine Start Starts the machine configuration
selected in the machine overview.

Restart Shuts down the SinuTrain machine and
then restarts it automatically.

Shut down Shuts down the SinuTrain machine.
The machine overview remains open.

Settings… Changes to the "Edit machine" window
in order to change the machine name,
description, language and machine
image as well as the resolution of the
SINUMERIK Operate user interface.

Extras Install additional HMI
languages...

Changes to the "Install additional HMI
languages" window in order to install
additional available languages for
SINUMERIK Operate.

Options... Changes to the "Options" window to
make the following settings:
· Selection of the language for the

SinuTrain user interface
· Activation or deactivation of

messages in SinuTrain for
SINUMERIK Operate (e.g. message
regarding possible data loss when
deleting a SinuTrain machine)
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Menu Menu commands Function
Window Split into single windows Splits the machine simulation window

into 3 individual windows that can be
moved:
· SINUMERIK Operate user interface
· Controls of an operator panel
· Machine control panel with feedrate

and spindle override
Note:
Only active once the machine has been
started.

Help Help on SinuTrain... Opens the online help for SinuTrain for
SINUMERIK Operate.

Help on SINUMERIK CNC-
SW

Opens the online help for release-
specific information.
The submenus depend on the installed
CNC software versions.

Info... Changes to the "About SinuTrain for
SINUMERIK Operate" window to obtain
the following information:
· Product version of the installed

SinuTrain for SINUMERIK Operate
· Data of the versions of all CNC

software packages in the "Installed
SINUMERIK CNC SW packages"
area
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A.2 Context menu
There is a context menu with the following commands for each machine page in the
machine overview:
Menu commands Function
Start Starts the machine configuration selected in the machine

overview.
Export... Opens the "Save as" dialog to export machine

configurations from the machine overview.
Copying and inserting Copies the machine selected in the machine overview and

inserts it in the list of machines.
You then change the properties of the copied machine via
the Machine > Settings... menu command or the
"Settings..." command in the context menu.

Delete Deletes the selected SinuTrain machine.
Settings… Changes to the "Edit machine" window in order to change

the machine name, description, language and machine
image as well as the resolution of the SINUMERIK
Operate user interface.
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A.3 Operation with standard PC keyboard
The following keys and key combinations are available for operation of SinuTrain
SINUMERIK Operate.
PC keyboard Function
<F1> ... <F8> Horizontal softkeys 1 to 8
Shift + <F1> ... <F8> Vertical softkeys 1 to 8
<F9>

Shift + <F9>

<F10>

Shift + <F10>

<F11>

<F12>

<Page↑>

<Page↓>

<Enter>
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PC keyboard Function
<Insert>

Numerical block <5>

<Esc>

<Ctrl> + <Alt> + <Shift> + <1>

<Ctrl> + <Alt> + <Shift> + <2> The operational SinuTrain machine is run down.
<Ctrl> + <Alt> + <Shift> + <3>

<Ctrl> + <Alt> + <Shift> + <4>

<Ctrl> + <Alt> + <Shift> + <5>

<Ctrl> + <Alt> + <Shift> + <6>

<Ctrl> + <Alt> + <Shift> + <7>
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